Tell me more ×
Programmers Stack Exchange is a question and answer site for professional programmers interested in conceptual questions about software development. It's 100% free, no registration required.

I think this is the right stack for this.

I have a helper class which builds CAML queries (SharePoint XML for getting list items from SQL)

There is one method that is flexibly used to build the queries that get all related votes and comments for a social item.

I don't want to call it BuildVoteorCommentXML or something long winded like that. Is there a good naming convention for getting all Join/Foreign Key objects from a core object?

share|improve this question

closed as not constructive by Jim G., Walter, Yannis Rizos Aug 28 '12 at 17:15

As it currently stands, this question is not a good fit for our Q&A; format. We expect answers to be supported by facts, references, or specific expertise, but this question will likely solicit debate, arguments, polling, or extended discussion. If you feel that this question can be improved and possibly reopened, see the FAQ for guidance.

2 Answers

up vote 1 down vote accepted

The XML is purely transport for the query and nothing to do with the functionality so including "XML" in the class name adds very little to the meaning.

The function you are writing builds voter and comment queries so something like "VoteAndCommentQuery" would be a better class name.

share|improve this answer

I think a good name is the one that passes enough information without being too long.

What about SocialDetailsXMLBuilder ?

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.