Tagged Questions
6
votes
1answer
144 views
Naming of related classes and interfaces
I have created an ObjectParser class which parses data into strongly typed objects using an IObjectParserDataSource as the data source (the data could be an Excel file, text file, array, query string, ...
2
votes
4answers
176 views
Derived Class Method Naming
I'm having a hard time coming up with a good naming convention for methods in derived classes that serve the same purpose as the methods in the base class. For example, if both the base class, and the ...
0
votes
1answer
177 views
Is C# namespace should be Project-Name?
I am working with multiple websites (freelancer) and a good amount of them I write using C# MVC4.
I created a very good boilerplace project that I plan to use on every next starting mvc4 application ...
3
votes
1answer
181 views
What should be done with class names that conflict (common) framework names
What should be done exactly when the most obvious class name for a component is taken by a framework? In my case, I need to make a class that describes an HTTP request. Of course, the most common name ...
5
votes
3answers
297 views
Naming Convention for Dedicated Thread Locking objects
A relatively minor question, but I haven't been able to find official documentation or even blog opinion/discussions on it.
Simply put: when I have a private object whose sole purpose is to serve for ...
7
votes
2answers
2k views
c# class naming standards/guidelines
Over the years I've used various naming conventions for services in my applications
for example:
[ClassName]Service
[ClassName]Manager
[ClassName]Factory
[ClassName]Provider
...
-2
votes
2answers
105 views
Proper Method name for XML builder [closed]
I think this is the right stack for this.
I have a helper class which builds CAML queries (SharePoint XML for getting list items from SQL)
There is one method that is flexibly used to build the ...
0
votes
2answers
259 views
Identify name of class which does CRUD operations
Using my application (which I am currently developing), Admin can assign addresses (not only assign, it is something like CRUD operations) to salesRep, so that those addresses will be listed under ...
10
votes
8answers
3k views
Variable naming conventions?
I've just started using ReSharper (for C#) and I kind of like its code smells finder, it shows me some things about my writing that I meant to fix a long time ago (mainly variable naming conventions). ...
3
votes
6answers
703 views
“As” Naming Convention
I'm experimenting with a naming convention I've devised and am seeking opinion. It involves the use of an "As" infix, and at this point I am envisioning it in the context of JavaScript, C# and C++ ...
14
votes
13answers
1k views
async & await - poll for alternatives [closed]
Now that we know what is in store for c#5, there is apparently still an opening for us to influence the choice of the two new keywords for 'Asynchrony' that were announced by Anders Heijsberg ...
4
votes
7answers
903 views
What is it called when you set properties on object initialization?
What is it called when you set properties on object initialization?
var customer = new Customer() {RequestID = request.ID, AddressID = 5};
Is it considered good practice?
5
votes
3answers
841 views
What should I name this helper class? [closed]
Usually when writing unit tests I create a helper class with extension methods. I use these methods exclusively for generating generic data for things that I am too lazy to type out. I usually name ...
5
votes
5answers
620 views
When inheriting from a class in C#, which naming convention is preferred?
If you inherit from Tile, for example, should the subclass be called CollisionTile or just Collision? What about for painting tools in an application like Paint? PenTool or just Pen?
Are there any ...
6
votes
5answers
1k views
What's a good naming convention for generic types in C#? [closed]
I decided to ask this question here instead of on stack overflow because it is rather subjective.
In C#, typically I see generic types with very poor names. Specifically, "T" is commonly used but is ...