Codul de eroare 0x800B0100 când utilizaţi Windows Update sau Microsoft Update pentru a instala actualizări

ID articol: 956702 - Vizualizaţi produsele pentru care se aplică acest articol.
Măriţi totul | Reduceţi totul

În această pagină

SIMPTOME

Când încercaţi să instalaţi actualizări de la site-ul Web Windows Update sau site-ul Web Microsoft Update, este posibil să primiţi următorul mesaj de eroare:
0x800B0100

CAUZĂ

Această problemă apare dacă fişiere .dll de securitate din Windows sunt înregistrate incorect.

REZOLUŢIE

Pentru a rezolva această problemă, utilizaţi următoarele metode în conformitate cu sistemul de operare Microsoft Windows pe care
îl utilizaţi.

Metoda pentru Windows 7, Windows Vista sau Windows Server 2008

Pentru a rezolva această problemă, executaţi System Update Readiness Tool (Checksur.exe). Pentru aceasta, urmaţi aceşti paşi:
  1. Descărcaţi şi executaţi System Update Readiness Tool. Acest instrument se execută o scanare unică pentru neconcordanţe care pot împiedica viitoare operaţiuni de întreţinere.
    Pentru informaţii suplimentare privind modul de descărcare şi executare a instrumentului Checksur.exe, faceţi clic pe următorul număr de articol pentru a vedea articolul în Baza de cunoştinţe Microsoft:
    http://support.microsoft.com/kb/947821/ro Descrierea instrumentului System Update Readiness Tool pentru Windows Vista
  2. Încercaţi să instalaţi din nou actualizările.
Notă După ce executaţi instrumentul, fişierul Checksur.log se află în următoarea locaţie: %systemroot%\Logs\CBS\

Într-o instalare implicită Windows 7 şi Windows Vista, acest fişier este în următorul folder:

C:\Windows\Logs\CBS

Metoda pentru Windows 2000, Windows XP sau Windows Server 2003

Dacă doriţi să remediem problema pentru dvs., continuaţi cu secţiunea „Remediere automată”. Dacă preferaţi să remediaţi dvs. problema, continuaţi cu secţiunea „Remediere personală”.

Remediere automată



Pentru o remediere automată a acestei probleme, faceţi clic pe linkul sau pe butonul Remediere. În caseta de dialog Descărcare fişier, faceţi clic pe Executare, apoi urmaţi paşii din expertul Fix it.


Remediere problemă
Microsoft Fix it 50652


Note
  • Este posibil ca acest expert să fie numai în limba engleză. Însă, remedierea automată funcţionează şi pentru Windows în alte limbi.
  • Dacă nu vă aflaţi la computerul care manifestă problema, salvaţi soluţia Fix it pe o unitate flash sau pe un CD, apoi executaţi-o pe computerul care manifestă problema.

Apoi continuaţi cu secţiunea „S-a remediat problema?”.



Remediere personală

Pentru a rezolva această problemă, înregistraţi fişierele Softpub.dll, Wintrust.dll, Initpki.dll şi Mssip32.dll. Pentru a înregistra aceste fişiere, urmaţi aceşti paşi:
  1. Faceţi clic pe Start, pe Executare, tastaţi cmd, apoi faceţi clic pe OK.
  2. La promptul de comandă, tastaţi regsvr32 Softpub.dll /s, apoi apăsaţi ENTER.
  3. La promptul de comandă, tastaţi regsvr32 Wintrust.dll /s, apoi apăsaţi ENTER.
  4. La promptul de comandă, tastaţi regsvr32 Initpki.dll /s, apoi apăsaţi ENTER.
  5. La promptul de comandă, tastaţi regsvr32 Mssip32.dll /s, apoi apăsaţi ENTER.

S-a remediat problema?

  • Verificaţi dacă s-a remediat problema. Dacă s-a remediat problema, aţi terminat cu această secţiune. Dacă problema nu s-a remediat, contactaţi asistenţa.
  • Apreciem părerea dvs. Pentru a vă spune părerea sau pentru a raporta orice problemă cu această soluţie, lăsaţi un comentariu în blogul „Remediere automată” sau trimiteţi-ne un mesaj de poştă electronică.

Proprietăți

ID articol: 956702 - Ultima examinare: 20 decembrie 2011 - Revizie: 2.0
SE APLICĂ LA:
  • Microsoft Windows Update
  • Microsoft Update
Cuvinte cheie: 
kbexpertiseinter kbtshoot kbprb kbfixme kbmsifixme KB956702

Trimiteți feedback