PRB: Windows Installer deja de responder por valores de configuración predeterminados de DCOM incorrectos

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Síntomas

Después de actualizar a Windows Installer versión 2.0, es posible que no se inicie el servicio de Windows Installer y que reciba el siguiente mensaje de error:
No se puede tener acceso al servicio Windows Installer. Esto puede ocurrir si está ejecutando Windows en Modo a prueba de errores, o si Windows Installer no está correctamente instalado. Póngase en contacto con el personal de soporte técnico para obtener asistencia.
NOTA
Este comportamiento no aparece en los productos siguientes:
  • Microsoft Windows XP
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98

Causa

Este comportamiento puede producirse cuando se da alguna de las condiciones siguientes:
  • En los permisos de DCOM, el nivel de autenticación predeterminado está establecido en Ninguno y el nivel predeterminado de Suplantación está establecido en Anónimo.
  • La cuenta del sistema no tiene los permisos Completos sobre una carpeta o clave del Registro a la que Windows Installer intenta obtener acceso. Esto es específico de NTFS.

Solución

Según el problema, utilice uno o todos los métodos siguientes:
  • Método 1: comprobar los permisos de DCOM.
  • Método 2: conceder el permiso Control completo a la cuenta SYSTEM.
  • Método 3: comprobar los permisos del Registro.
  • Método 4: arreglar la clave de seguridad dañada del servicio MsiServer.

Antes de comenzar: compruebe que esté instalado el Service Pack

Si usa Windows 2000, asegúrese de que esté instalado el SP 2.
Si usa Windows NT 4.0, asegúrese de que esté instalado el SP 6.

Si no instala los Service Pack adecuados, es posible que los pasos descritos en la sección "Más Información" de este artículo no den el resultado esperado.

Más información

Método 1: comprobar los permisos de DCOM

Este método implica cambiar el nivel de suplantación predeterminado de DCOM a Identificar, quitando el archivo Msisip.dll y reinstalando a continuación el SP 3 para Windows 2000.

Para ello, siga estos pasos:
  1. Haga clic en Inicio, en Ejecutar, escriba dcomcnfg y, a continuación, haga clic en Aceptar.
  2. En la ficha Propiedades predeterminadas:
    1. En la lista Nivel de autenticación predeterminado, haga clic en Conectar.
    2. En la lista Nivel de suplantación predeterminado, haga clic en Identificar y en Aceptar.
  3. Haga clic en Inicio y, después, en Ejecutar, escriba explorer /select, %windir%\system32\msisip.dll y, a continuación, haga clic en Aceptar.
  4. Cambie el nombre del archivo Msisip.dll a Msisip.old.
  5. Reinstale el Service Pack 3 para Windows 2000.

Método 2: conceder el permiso Control completo a la cuenta SYSTEM

  1. Inicie el Explorador de Windows, haga clic con el botón secundario del mouse (ratón) en la unidad de disco duro y, a continuación, haga clic en Propiedades.
  2. Haga clic en la ficha Seguridad y, a continuación, en Agregar.
  3. En el cuadro de diálogo Seleccionar usuarios, equipos o grupos, haga clic en la cuenta del sistema, haga clic en Agregar y, después, en Aceptar.
  4. En Permitir, active la casilla de verificación Control total y, a continuación, haga clic en Aceptar.
  5. Haga clic en la carpeta TEMP y, a continuación, compruebe que la cuenta del sistema tiene control total.

Método 3: comprobar los permisos del Registro

  1. Haga clic en Inicio, haga clic en Ejecutar y, a continuación, escriba Regedt32.
  2. Para cada una de las secciones del Registro, siga estos pasos:
    1. Seleccione la sección.
    2. Para Windows XP, en el menú Edición, haga clic en Permisos.

      Para Windows 2000 y Windows NT 4, en el menú Seguridad, haga clic en Permisos.
  3. Compruebe que se ha agregado la cuenta SYSTEM y que tiene control total. Si no es así, agréguela con control total.

Método 4: arreglar la clave del Registro dañada del servicio MsiServer

  1. Inicie el equipo utilizando Windows 2000.
  2. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit.exe y, a continuación, cambie el nombre a Old_Security de la siguiente clave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer\Security
  3. Debe reiniciar el equipo.
  4. Vuelva a ejecutar Instmsiw.exe para Installer 2.0; de este modo, se corrige la clave de seguridad dañada del servicio MSI.

Propiedades

Id. de artículo: 319624 - Última revisión: miércoles, 05 de mayo de 2004 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows Installer 1.0Sobre las siguientes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Service Pack 1 de Microsoft Windows 2000
    • Service Pack 2 de Microsoft Windows 2000
    • Service Pack 3 de Microsoft Windows 2000
  • Microsoft Windows Installer 1.1Sobre las siguientes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Service Pack 1 de Microsoft Windows 2000
    • Service Pack 2 de Microsoft Windows 2000
    • Service Pack 3 de Microsoft Windows 2000
  • Microsoft Windows Installer 1.2Sobre las siguientes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Service Pack 1 de Microsoft Windows 2000
    • Service Pack 2 de Microsoft Windows 2000
    • Service Pack 3 de Microsoft Windows 2000
  • Microsoft Windows Installer 2.0Sobre las siguientes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Service Pack 1 de Microsoft Windows 2000
    • Service Pack 2 de Microsoft Windows 2000
    • Service Pack 3 de Microsoft Windows 2000
Palabras clave: 
kbprb KB319624

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