My Java code has packages that look like, e.g.
me.unroll.monitoringclient
And we've largely followed this convention through - e.g., for RabbitMQ our queue names are things like
me.unroll.emails.GenerateEmail
So we're using Redis for message queueing too. I'm trying to make a very silly decision here: Stick with the .
convention or switch to :
which I've seen in a handful of Redis examples? Essentially I'm saying
me.unroll.emails.GenerateEmail
looks wrong in Redis - I've never seen a.
used in a queueme:unroll:emails:GenerateEmail
just looks really wrong in that I've never seen a colon delimiter used between a TLD and an SLD.
I'm also unsure how to namespace message queues that will be relying on a BLPOP mechanism. It's unclear to me whether me.unroll.queue
or me.unroll.<package>.queue
would be more intelligent, but I'm leaning the former.
This may be a trivial decision with not much in the way of serious implications, but I'd obviously like to follow convention as much as possible, so I'm wondering what the regarded practice for having intelligent namespaces in Redis is. And it's possible that I'm just oblivious to other considerations entirely (Instead of namespaces use a bunch of nested hashes? Sounds ridiculous but I'm new to this technology, and the sky is the limit).