Po stažení aktualizace z webu Windows Update nebo Microsoft Update nebo ze serveru Windows Server Update Services se zobrazí kód chyby 0x80070002 nebo 0x80070003

ID článku: 910336 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Automatická oprava potíží

Opravit tyto potíže
Microsoft Fix it 50202

Poznámka: Tato oprava má dva režimy: výchozí a agresivní. Před spuštěním v agresivním režimu spusťte opravu ve výchozím režimu a vyzkoušejte, zda vyřeší vaše potíže se službou Windows Update.

Poznámka: Chcete-li tyto potíže vyřešit sami, přejděte k části Manuální oprava.

Poznámka: Je možné, že tento průvodce bude k dispozici pouze v angličtině, tato automatická oprava však funguje i pro ostatní jazykové verze systému Windows.

Poznámka: Pokud právě nejste u počítače, který má tyto potíže, můžete opravu uložit na jednotku USB Flash nebo na disk CD a spustit ji v příslušném počítači později.
Byly tyto informace užitečné? Odešlete nám svůj názor

Příznaky

Stáhli jste aktualizaci z jednoho z následujících umístění:
  • web Windows Update,
  • web Microsoft Update,
  • server WSUS (Windows Server Update Services).
Poté může aktualizace selhat a u aktualizace se zobrazí obrázek červeného X. V takovém případě se zobrazí některý z následujících kódů chyb:
  • 0x80070002
  • 0x80070003
Poznámka: Chcete-li zobrazit chybové zprávy, klepněte na obrázek červeného X u neúspěšné aktualizaci na webové stránce Zobrazit historii aktualizací.

Příčina

K tomuto problému dochází, pokud v aktualizaci chybí některé soubory, i když byla aktualizace úspěšně stažena a extrahována.

Manuální oprava

Pokud chcete tyto potíže vyřešit sami, odeberte adresář, do kterého jste stáhli soubor, a znovu navštivte web umístění aktualizace.
  1. Zastavte službu Automatické aktualizace. Postupujte následujícím způsobem:
    1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz services.msc a pak klepněte na tlačítko OK.
    2. Klepněte pravým tlačítkem myši na službu Automatické aktualizace a pak vyberte příkaz Zastavit.
    3. Minimalizujte modul snap-in Služby.
  2. Přejmenujte adresář SoftwareDistribution. Postupujte následujícím způsobem:
    1. Klepněte na tlačítko Start a na příkaz Spustit, zadejte příkaz cmd a potom klepněte na tlačítko OK.
    2. Zadejte příkaz cd %windir% a stiskněte klávesu ENTER.
    3. Zadejte příkaz ren SoftwareDistribution SDTemp a stiskněte klávesu ENTER
    4. Zadejte příkaz exit a stiskněte klávesu ENTER.


    Poznámka: Když odeberete složku %windir%\softwaredistribution, bude vymazán seznam historie v části Zkontrolovat aktualizace na webu Windows Update. Tato akce neovlivní aktuálně nainstalované aktualizace v počítači. Následné aktualizace se v seznamu historie zobrazí.
  3. Spusťte službu Automatické aktualizace. Postupujte následujícím způsobem:
    1. Maximalizujte modul snap-in Služby.
    2. Klepněte pravým tlačítkem myši na službu Automatické aktualizace a pak vyberte příkaz Spustit.
    3. Zavřete okno modulu snap-in Služby.
  4. Navštivte znovu web Windows Update, Microsoft Update nebo server WSUS a stáhněte nějakou aktualizaci.
  5. Pokud se stále zobrazují stejné chyby, zkontrolujte, zda jste správně vykonali kroky 1 až 3.
  6. Pokud stále nemůžete nainstalovat aktualizaci, vyhledejte informace v následujícím článku znalostní báze Microsoft Knowledge Base:
    906602 Postup řešení problémů s instalací u služeb Windows Update, Microsoft Update a Windows Server Update

Vlastnosti

ID článku: 910336 - Poslední aktualizace: 29. července 2011 - Revize: 6.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Update
  • Microsoft Windows Update
Klíčová slova: 
kbtshoot kbmsifixme kbfixme KB910336

Dejte nám zpětnou vazbu