"Search cannot return results for this view" error in the People Pane in Outlook 2013 or Outlook 2010

Article ID: 976786 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms

In the People Pane in Microsoft Outlook 2013 or Outlook 2010, the Social Connector feature does not display information about contacts, such as activities, meetings, status updates, email messages, or meetings. Instead, the following text is displayed: 

There are no items to show in this view.
Additionally, a warning bar displays the following notices in the People Pane:

Search cannot return results for this view. Click here for more information.
Collapse this imageExpand this image



Note In this scenario, you receive one of the following error messages when you try to perform a search in Outlook: 
  • Instant Search is not available when Outlook is running with administrator permissions. To use Instant Search, exit and restart Outlook without administrator permissions.
  • The Windows Search service is not installed. Outlook cannot provide fast search results using the Instant Search feature unless this service is installed.
  • To enable the Instant Search feature in Outlook, you must download and install a component for Microsoft Windows.

Cause

This problem occurs because the Outlook Social Connector feature depends on Windows Search to provide information in the People Pane. However, the Windows Search functionality is not available in either of the following scenarios: 
  • You run Outlook by using administrator-elevated permissions.
  • You do not have Windows Search installed.

Resolution

To resolve this issue, following these steps.

Step 1: Make sure that you run Outlook without using the "Run as administrator " command

Exit Outlook 2010, right-click the Outlook shortcut that you use to open Outlook, and then click Properties. On the Compatibility tab, make sure that the Run this program as an administrator option in not selected. When you run Outlook, do not use the Run as administrator command.

Step 2: Install the Windows Search components by using Programs and Features

For Windows 7 or Windows 8

Collapse this imageExpand this image
If you are running Windows 7 or Windows 8, follow these steps to add this feature to your Windows installation. 
  1. Exit Outlook.
  2. In Control Panel, click Programs and Features.
  3. In the navigation pane, click Turn Windows features on or off.
  4. In the Windows Features dialog box, locate and then click to select the Windows Search check box. 

    Collapse this imageExpand this image
    Windows Features
  5. Click OK.
  6. After the Windows Search feature is installed, click Restart Now to restart your computer.
  7. Start Outlook after your computer restarts.

    Note You may see a dialog box that resembles the following when Outlook is first started after you make this change to your Windows 7 installation.

    Collapse this imageExpand this image
    Outlook installing Windows Search
Collapse this imageExpand this image

For Windows XP or Windows Vista

Collapse this imageExpand this image
If you are running Windows XP or Windows Vista, and if Windows Search 4.0 is not installed, you must install Windows Search 4.0. To download the update, visit the following Download Center pages for your version of Windows: 
Windows Search 4.0 for Windows XP (KB940157)

Windows Search 4.0 for Windows Vista SP1 (KB940157)

For more information about how to install Windows Search 4.0, click the following article number to view the article in the Microsoft Knowledge Base:
940157 Description of Windows Search 4.0 and the Multilingual User Interface Pack for Windows Search 4.0
Collapse this imageExpand this image

Workaround

Disable the notification messages

If you do not want to want to install the necessary Windows Search components, and if you want to disable the following alerts, you must modify the Windows registry. (Click + to expand this section.)

Collapse this imageExpand this image


Collapse this imageExpand this image
To have us disable the notification messages for you, go to the " Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix it button or link. Click Run in the File Download dialog box, and follow the steps in the Fix it wizard.
Collapse this imageExpand this image
Fix this problem
Microsoft Fix it 50516
Collapse this imageExpand this image


Notes
  • This Fix it only applies to Outlook 2010. If you are running Outlook 2013, please go to Let me fix it myselfsection.
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not using the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

To disable these alerts yourself, follow these steps to update the Windows registry:

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following subkey in the registry:

    For Outlook 2010
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook\Search


    For Outlook 2013
    HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\Search

    Note You must manually create this subkey in the registry if this subkey currently does not exist. To do this, follow these steps:
    1. Locate and then click the following subkey in the registry:
      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Outlook
    2. On the Edit menu, point to New, and then click Key.
    3. Type Search, and then press ENTER.
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type DisableDownloadSearchPrompt, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 1, and then click OK.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an  email.
    Collapse this imageExpand this image

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 976786 - Last Review: July 30, 2013 - Revision: 11.0
Applies to
  • Microsoft Outlook 2010
  • Microsoft Outlook 2013
Keywords: 
kbexpertiseinter kbtshoot kbsurveynew kbprb kbfixme kbmsifixme KB976786

Give Feedback