I would like a review of how I am comparing two java.util.String
in a private method in a java.util.Comparator
. Either of the String
s could be null or blank, and would be "less than" the other String
if that other String
were not null/blank.
My gut feeling is that this is at the very least inelegant, probably difficult to read, and at worst inefficient if it had to be done millions of times per second. Oh, and there could even be a flaw in the logic!
Is there a better way to do this?
private Integer compareDateStrings(BeanToDoTask arg0, BeanToDoTask arg1, String strProperty) {
/* Don't worry too much about this part. */
String strDate0 = BeanUtils.getProperty(arg0, strProperty); _logger.debug("strDate0 = " + strDate0);
String strDate1 = BeanUtils.getProperty(arg1, strProperty); _logger.debug("strDate1 = " + strDate1);
/* If strDate0 is null or blank and strDate1 is not, then strDate1 is greater. */
if ((strDate0 == null || strDate0.equals(""))) {
if (strDate1 != null && !strDate1.equals("")) {
return -1;
} else {
/* They both are null or blank! */
return 0;
}
}
/* We know strDate0 is not null or blank. */
if (strDate1 == null || strDate1.equals("")) {
return 1;
}
/* At this point neither strDate0 or strDate1 are null or blank, so let's compare them. */
return strDate0.compareTo(strDate1);
}