Viene visualizzato un codice di errore "0x80070002" o "0x80070003" dopo avere scaricato un aggiornamento da Windows Update, Microsoft Update o da Windows Server Update Services

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Correggere il problema automaticamente

Correggi problema
Microsoft Fix it 50202

Nota La soluzione Fix it dispone di due modalità Predefinita e Aggressiva. Prima di eseguire la soluzione Fix it in modalità Aggressiva, è necessario eseguirla in modalità Predefinita e verificare se questa risolve il problema con Windows Update.

Nota Per risolvere autonomamente il problema, andare alla sezione "Correzione manuale".

Nota Questa procedura guidata potrebbe essere disponibile esclusivamente in inglese. Tuttavia, la correzione automatica funziona anche per le versioni di Windows in altre lingue.

Nota Se non si sta utilizzando il computer che presenta il problema, è possibile salvare la soluzione Fix it su un'unità di memoria flash o su un CD ed eseguirla sul computer che presenta il problema.
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Sintomi

Si scarica un aggiornamento da uno dei seguenti percorsi:
  • Il sito Web Microsoft Windows Update
  • Il sito Web Microsoft Update
  • Il server Microsoft WSUS (Windows Server Update Services)
Dopo questa operazione l'aggiornamento potrebbe non andare a buon fine e una X rossa potrebbe essere visualizzata accanto all'aggiornamento. In questo caso viene visualizzato uno dei seguenti codici di errore:
  • 0x80070002
  • 0x80070003
Nota Per visualizzare i messaggi di errore, è necessario fare clic sulla X rossa accanto all'aggiornamento non riuscito nella pagina Web Verifica cronologia aggiornamenti.

Cause

Questo problema si verifica quando alcuni file dell'aggiornamento risultano mancanti, anche se l'aggiornamento viene scaricato ed estratto in modo corretto.

Correzione manuale del problema

Per risolvere il problema autonomamente, rimuovere la directory di download e visitare di nuovo i percorsi di aggiornamento.
  1. Arrestare il servizio Aggiornamenti automatici. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, scegliere Esegui, digitare services.msc, quindi scegliere OK.
    2. Fare clic con il pulsante destro del mouse sul servizio Aggiornamenti automatici, quindi scegliere Arresta.
    3. Ridurre a icona lo snap-in Servizi.
  2. Rinominare la directory SoftwareDistribution. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, scegliere Esegui, digitare cmd, quindi scegliere OK.
    2. Digitare cd %windir% e premere INVIO.
    3. Digitare ren SoftwareDistribution SDTemp, quindi premere INVIO.
    4. Digitare exit, quindi premere INVIO.


    Nota Quando si rimuove la cartella %windir%\softwaredistribution, l'elenco cronologia viene cancellato dalla sezione relativa alla verifica degli aggiornamenti del sito Web Windows Update. Questa operazione non influirà sugli aggiornamenti correntemente installati nel computer. Gli aggiornamenti successivi verranno visualizzati nell'elenco cronologia.
  3. Avviare il servizio Aggiornamenti automatici. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Ingrandire lo snap-in Servizi.
    2. Fare clic con il pulsante destro del mouse sul servizio Aggiornamenti automatici, quindi scegliere Avvia.
    3. Chiudere la finestra dello snap-in Servizi.
  4. Visitare di nuovo il sito Web Windows Update, Microsoft Update o il server WSUS e scaricare un aggiornamento.
  5. Se si verificano ancora gli stessi errori, controllare di avere eseguito correttamente i passaggi da 1 a 3.
  6. Se ancora non è possibile installare l'aggiornamento, vedere il seguente articolo della Microsoft Knowledge Base:
    906602 Risoluzione dei problemi di installazione di Windows Update, Microsoft Update e Windows Server Update Services

Proprietà

Identificativo articolo: 910336 - Ultima modifica: lunedì 1 agosto 2011 - Revisione: 4.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Update
  • Microsoft Windows Update
Chiavi: 
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